Store Menu

Camera Raw Update – Aperture Gets RX1 support

Apple has issued another Camera raw support update with support for a few new cameras including the groundbreaking Sony RX1. Here’s the full list of what’s added…

Leica D-Lux 6
Leica V-Lux 4
Leica X2
Nikon D5200
Pentax K-5 II
Pentax K-5 IIs
Pentax K-30
Pentax Q
Sony Cyber-shot DSC-RX1

Full details available on Apple’s website

,

10 Responses to Camera Raw Update – Aperture Gets RX1 support

  1. Ric February 8, 2013 at 12:08 am #

    STILL NOTHING FOR THE FUJIFILM X-PRO 1 OR X-E1. Getting to the point where I’m forced to abandon Aperture and switch to Lightroom or Capture One.

    There’s no reason not to say if Apple is planning to support it. Its competitors already do. So Apple should either alert its users to an intention to support these cameras, or let us assume it have no intention of ever doing it. There is no rational reason in this circumstance for continued secrecy.

  2. matt February 8, 2013 at 1:11 am #

    Oh Apple, how I wish you would release Fuji X-Pro1 RAW support. Its way too nice of a camera to shrug it off. The x-mount is only going to get more popular and by then, I’m afraid, too many people will have left for LR. OK, off my soapbox now… I wish I didn’t enjoy using Aperture so much or I would’ve switched by now!

    • Thomas Fitzgerald February 19, 2013 at 11:25 am #

      For those wanting Fuji X Support don’t hold your breath. From what I understand about Aperture’s programming, Aperture doesn’t have the underlying architecture can’t support non – bayer standard cameras. I could be wrong, but I’m pretty sure. You’ll notice that none of the Foveon sensors are supported either.

      I’m guessing there’ll have to be a major change before we see it. If ever.

      • Ebony February 21, 2013 at 5:27 am #

        Thomas Fitzgerald you’re comment makes me want to cry. I hope you are incorrect in your assumption and Aperture develops RAW support for the X-Pro1, X-E1 and other X-mount cameras.
        There is already support for the X100 so I don’t see why they wouldn’t for the rest of the X Series.

  3. Bob February 19, 2013 at 11:23 am #

    Does anyone have the same problem? Aperture 3.4.3 keeps crashing when ejecting a Sony RX1. Every few crashes Aperture then ask for a rebuild of the database and/or a permissions repair. Does the problem come from the Aperture update or from the camera… Any ideas?
    Thanks

    • Thomas Fitzgerald February 19, 2013 at 11:26 am #

      I think it’s an Aperture bug. Mine keeps asking me to rebuild every now and then too for no reason.

      • Bob February 19, 2013 at 2:38 pm #

        “… for no reason.” and not after a crash at ‘Eject’ camera?

        • Thomas Fitzgerald February 19, 2013 at 2:39 pm #

          No – every now and again when launching it

  4. Bob February 19, 2013 at 2:48 pm #

    OK, thanks.
    I found that ejecting the camera through the desktop (Mac) avoids the crash.

Powered by WordPress. Designed by Woo Themes